U P P E R

Yes, SaasLand is compatible with WordPress 5.0 and higher versions.